BVN Service Downtime
Incident Report for Blusalt FS
Resolved
This incident has been resolved.
Posted Aug 20, 2021 - 16:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 20, 2021 - 15:49 UTC
This incident affected: Identity Services (BVN Service).