Intermittent Availability

Incident Report for Blusalt FS

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:31 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:27 UTC

Monitoring

Cloudflare has indicated that the service is recovering.
Posted Nov 18, 2025 - 12:26 UTC

Identified

We've identified an issue with our upstream provider Cloudflare causing connectivity issues with some of our services.
Posted Nov 18, 2025 - 12:02 UTC
This incident affected: Blusalt Payments (Blusalt Wallet, Reserved Accounts, Card Processing, Payment Pro), Identity Services (NIN Verification, BVN Service, Facial Recognition Service), Card Issuing (API), and Funds Transfer Service.