Transaction Processing Delay

Incident Report for Blusalt FS

Resolved

This incident has been resolved.
Posted Sep 05, 2024 - 14:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 05, 2024 - 14:19 UTC

Update

We are continuing to investigate this issue.
Posted Sep 05, 2024 - 14:14 UTC

Investigating

We are currently investigating this issue.
Posted Sep 05, 2024 - 14:12 UTC
This incident affected: Blusalt Payments (Reserved Accounts, Card Processing).