Issue with Sending out OTPs

Incident Report for Blusalt FS

Resolved

This incident has been resolved.
Posted Jan 17, 2022 - 08:54 UTC

Investigating

We are aware of an issue with sending out OTPs at the moment. This might affect withdrawing funds, and other services.
We are currently looking into this.
Posted Jan 17, 2022 - 08:18 UTC
This incident affected: Blusalt Payments (Blusalt Wallet).