System Outage
Incident Report for Blusalt FS
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 07:30 UTC
Investigating
This appears to be caused by an issue with our Service Provider, Cloudflare.
We are investigating and will provide updates soon
Posted Jun 21, 2022 - 06:56 UTC
This incident affected: Blusalt Payments (Blusalt Wallet, Reserved Accounts), Identity Services (NIN Verification, BVN Service, Facial Recognition Service), and Funds Transfer Service.