Infrastructure Connectivity Issue
Incident Report for Blusalt FS
Resolved
This incident has been resolved.
Posted May 24, 2023 - 08:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2023 - 07:05 UTC
Investigating
We are currently investigating this issue.
Posted May 24, 2023 - 04:28 UTC
This incident affected: Blusalt Payments (Blusalt Wallet, Reserved Accounts, Card Processing), Identity Services (NIN Verification, BVN Service, Facial Recognition Service), and Funds Transfer Service.