Wallet Funding
Incident Report for Blusalt FS
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 10:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 11, 2021 - 10:46 UTC
Investigating
You might not be able to fund your wallet at the moment due to an issue with one of our providers. We expect the issue to be resolved within the hour. We will provide an update once the issue is resolved.
Posted Nov 11, 2021 - 10:46 UTC
This incident affected: Blusalt Payments (Blusalt Wallet).