Delayed Bank Transfer Processing

Incident Report for Blusalt FS

Resolved

This incident has been resolved.
Posted Jul 16, 2024 - 17:54 UTC

Investigating

We are currently investigating this issue.
Posted Jul 16, 2024 - 14:46 UTC
This incident affected: Blusalt Payments (Reserved Accounts) and Funds Transfer Service.