Delay in Processing
Incident Report for Blusalt FS
Resolved
This incident has been resolved.
Posted May 05, 2023 - 16:54 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 05, 2023 - 15:45 UTC
Identified
We had an infrastructure incident earlier today that might have caused delay in processing some transactions.
We are looking into resolving this as soon as possible.
Posted May 05, 2023 - 15:44 UTC
This incident affected: Blusalt Payments (Blusalt Wallet, Reserved Accounts) and Funds Transfer Service.