Issue with Bank Transfer Service

Incident Report for Blusalt FS

Resolved

This incident has been resolved.
Posted Jun 13, 2022 - 13:47 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 13, 2022 - 13:47 UTC

Identified

We have identified that some funds transfers are failing.
The issue has been identified and we are looking into resolving it as so as possible.
Posted Jun 13, 2022 - 12:00 UTC
This incident affected: Blusalt Payments (Blusalt Wallet) and Funds Transfer Service.