Delay in Virtual Account Processing

Incident Report for Blusalt FS

Resolved

This incident has been resolved.
Posted May 13, 2026 - 08:18 UTC

Monitoring

We are monitoring an issue with NIBSS causing delays in processing bank payments.
Posted May 12, 2026 - 17:20 UTC
This incident affected: Blusalt Payments (Reserved Accounts) and Funds Transfer Service.