Infrastructure Downtime
Incident Report for Blusalt FS
Resolved
This incident has been resolved.
Posted Aug 26, 2021 - 14:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 26, 2021 - 13:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 26, 2021 - 13:45 UTC
This incident affected: Blusalt Payments (Blusalt Wallet), Identity Services (NIN Verification, BVN Service, Facial Recognition Service), and Funds Transfer Service.