Card Transaction Processing

Incident Report for Blusalt FS

Postmortem

We had an issue with one of our internal payment processing services that caused international card transactions to not be processed for about 2 minutes around 10:30 AM GMT.
The issue was resolved automatically.

Posted Nov 23, 2024 - 12:55 UTC

Resolved

We had an issue with one of our internal processing services that caused international card transactions to not be processed for about 2 minutes around 10:30 AM GMT.
The issue was resolved automatically.
Posted Nov 23, 2024 - 10:30 UTC