We have mitigated the issue for new accounts but some accounts created in the last 3 days might still be affected.
Posted Nov 16, 2023 - 16:05 UTC
Identified
An issue has been identified with Polaris bank virtual accounts where the account generated might not have a correct name. We have escalated this to the provider and are waiting for a fix.
Posted Nov 13, 2023 - 09:53 UTC
This incident affects: Blusalt Payments (Blusalt Wallet, Reserved Accounts).